Rails 4.2 upgrade and PG gem

Quick note friends. If you've recently upgraded to Rails 4.2 and seen your pg gem updates go to hell, there's a quick fix. Run this from terminal:

sudo ARCHFLAGS="-arch x86_64" gem install pg


The above seems to work with many "gem install pg" or "gem update pg" issues you encounter.

(image courtesy of http://www.hak9.com/

TJ
Feb. 03 2015